Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación. Si continúa navegando, consideramos que acepta su uso. Para obtener más información o bien conocer cómo cambiar la configuración lea nuestra Política de cookies

Reutilizar un documento inicial guardado en OpenOffice Writer

Si en un momento posterior queremos reutilizar el documento inicial que en el punto anterior almacenamos, deberemos seguir los pasos que a continuación se indican.

Abrir el documento inicial

El documento inicial es un documento de Writer que contiene campos asociados a una base de datos. Pero a la hora de abrir este documento no hay diferencia alguna con cualquier otro.

Puedes abrirlo siguiendo cualquiera de los métodos que se indicaron en los temas Abrir un Documento Existente o Abrir un documento reciente de este manual.

Agregar campos al documento inicial

Podremos agregar nuevos campos de la base de datos al documento. Desde el diálogo que abre el menú Insertar > Campos > Otros activamos la pestaña Base de datos.

En Tipo de campo seleccionaremos Campos de combinación de correspondencia. A la derecha se presentarán las bases de datos disponibles para combinar correspondencia.

OpenOffice.Writer.Combinar.Correspondencia.001.png

En la lista Seleccionar base de datos podemos hacer clic en el signo + de la base de datos para que se muestren sus tablas y consultas. Seleccionada la tabla, puedes hacer clic en el signo + que aparece delante de su nombre para que se muestren sus campos. Sólo te queda hacer clic y arrastrar el campo al documento, o bien, seleccionar el campo y hacer clic en el botón Insertar para que éste se agregue al documento justo en donde esté situado el punto de inserción.

Modificar el documento

Puedes modificar el documento, teniendo especial cuidado con los campos insertados (que se muestran entre los signos < >). Cambia el texto, los estilos, inserta imágenes..., cuantas acciones precises.

Insertar un campo condicional

Supongamos que si el campo <Provincia> es idéntico al campo <Poblacion> no deseamos que se muestren ambos, sino uno sólo.

La fuente de datos que estamos utilizando en este ejemplo se llama SBS, y la tabla en la que están los campos se llama CLIENTES.

En este caso deberíamos proceder del siguiente modo:

  • Eliminamos el campo <Provincia>
  • Con el cursor situado donde debería aparecer (o no) la provincia:
  • Mostramos el diálogo Campos desde el menú Insertar > Campos > Otros
  • Hacemos clic en la ficha Funciones
  • En Tipo de campo seleccionamos Texto condicionado
  • En Condición escribimos SBS.CLIENTES.Poblacion EQ SBS.CLIENTES.Provincia, que significa si el campo población de la tabla clientes de la base de datos sbs coincide con el campo provincia de la tabla clientes de la base de datos sbs
  • En Entonces no escribimos nada, pues si coinciden no queremos que se muestre la provincia
  • En Si no escribimos SBS.CLIENTES.Provincia que significa muestra el campo provincia de la tabla clientes de la base de datos sbs'
  • Hacemos un sólo clic en el botón Insertar
  • Hacemos clic en el botón cerrar.
Insertar un campo condicional para combinar correspondencia
Si está activado Mostrar el sombreado de campos (
Ctrl + F8 
) se mostrará un pequeño rectángulo gris en la posición en la que hemos insertado el campo condicional. Al combinar la correspondencia comprobaremos que si la provincia y la población coinciden, no se muestra la provincia.

Activar el asistente

Finalmente, activa de nuevo el asistente desde el menú Herramientas > Asistente para combinar correspondencia.

  • En el paso 1, selecciona Usar el documento actual y haz clic en Siguiente >>.
  • En el paso 2, selecciona Carta y haz clic en Siguiente >>.
  • En el paso 3 no será preciso agregar un bloque de direcciones, pues ya fue insertado anteriormente.
  • En el paso 4 no será preciso agregar un saludo, pues ya fue insertado anteriormente.
  • El paso 5 aparecerá atenuado, ya que los dos pasos anteriores no han sido activados.
  • A partir de aquí, no hay diferencia entre crear un documento nuevo y utilizar uno ya existente.
Modificada el 30 ago 2015 17:31.   Visitas: 8744