Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación. Si continúa navegando, consideramos que acepta su uso. Para obtener más información o bien conocer cómo cambiar la configuración lea nuestra Política de cookies

Fórmulas con funciones en OpenOffice Calc

Hemos visto como utilizar las fórmulas para realizar operaciones en una celda, o para operar con otras celdas. Pero una fórmula también puede incorporar funciones.

¿Y qué son las funciones? En el capítulo Las funciones las trataremos de forma ámplia. Por el momento, tan sólo necesitamos conocer que una fórmula puede incorporar funciones, y que podemos operar éstas (en realidad, el resultado que nos entrega la función) con otras celdas o valores constantes.

Veamos un ejemplo sencillo para incorporar una función dentro de una fórmula; además, este ejemplo se basará en la única función que posee un botón propio para ser introducida en una fórmula: la función SUMA.

En el sencillo ejemplo que hemos estado utilizando hasta el momento, disponíamos de dos números introducidos en las celdas B4 y B5. Podemos sumarlos y presentar el resultado de la suma en la celda B6, y hemos aprendido un método para hacerlo. Ahora vamos a utilizar una fórmula que incorpora una función para obtener exactamente el mismo resultado. Veamos el guión:

  • Sitúate en la celda B6
  • Haz clic sobre el botón Botón SUMA de la barra de fórmulas.
  • Calc introduce de forma automática una fórmula en la que únicamente existe una función; se llama SUMA, y entre paréntesis se le dice a la función qué es lo que queremos que sume; en nuestro caso, el rango de celdas B4:B5.
  • Finalizar el modo edición de fórmula.
Calc.33x.14.003.png

Hemos dicho que podemos operar el resultado de la función con otras celdas y/o valores. Nada nos impide restar al resultado de la función SUMA el contenido de la celda C14:  =SUMA(B4:B5)-C14  Tampoco hay problema en calcular el 20% de esta operación:  =(SUMA(B4:B5)-C14)*20%  Como ves, hemos tenido que añadir paréntesis para cumplir con las normas de prioridad de los operadores, de la que hablaremos más adelante. Y vemos también que existen dos usos de los paréntesis: para priorizar operaciones o para decirle a una función con qué datos tiene que trabajar.

Asímismo, trataremos con profundidad todos los aspectos del botón SUMA en el apartado La función SUMA.

Modificada el 23 ago 2015 19:35.   Visitas: 53 942