Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación. Si continúa navegando, consideramos que acepta su uso. Para obtener más información o bien conocer cómo cambiar la configuración lea nuestra Política de cookies

Ejemplo práctico: Cambiar un color a transparente en Draw

Algunas aplicaciones, que no pueden manejar adecuadamente la transparencia, muestran las zonas transparentes con el color Magenta, almacenando el gráfico con ese color y sin la información de transparencia.

Draw G32 06.065.png Draw G32 06.063.png
Imagen de mapa de bits con transparencia.
La imagen de la derecha es la misma, pero después de ser guardada con MS Paint.
El área transparente ha sido sustituido por el color magenta.

Si lo precisas, la herramienta Pipeta puede volver a crear la transparencia de la imagen.

Señal aviso.png


A partir de la versión AOO 3.4 la herramienta Pipeta se llama Reemplazar colores
Puedes activarla desde el menú Herramientas > Reemplazar colores
 
Draw G32 06.090.png
Abre el diálogo Pipeta desde el menú Herramientas > Pipeta y haz clic sobre la imagen a editar.
Draw G32 06.088.png
Ahora, haz clic sobre el icono Draw G32 06.089.png para activar el modo Selección de color. Verás como fuera del diálogo, el cursor toma forma de mano. El campo junto al icono muestra inmediatamente el color sobre el que vas situando el cursor.
Draw G32 06.084.png
Haz clic sobre el color que va a ser cambiado. En la primera línea del área Colores se mostrarán ciertos cambios. Se marcará la casilla Color fuente y el color seleccionado aparecerá en el cuadro adjunto. En Reemplazar por..., la opción Transparente está seleccionada.
Draw G32 06.081.png
Figura 22: Se ha sustituido el color magenta por transparencia
Haz clic sobre el botón Reemplazar (arriba a la derecha) para aplicar los cambios a la imagen (Figura 22).

No hay vista previa del efecto. Si el resultado no es el esperado, selecciona Edición > Deshacer.

El diálogo no se cierra automáticamente, por lo que puedes definir más sustituciones de color. Haz clic sobre el campo de la siguiente línea, y luego haz clic sobre la pipeta, repitiendo el proceso. Cierra el diálogo Pipeta cuando finalices desde su botón Cerrar o pulsando la combinación de teclas
Ctrl + F4 
.

Draw utiliza un canal Alpha para transparencia, por lo que pixels de diferentes colores pueden ser definidos transparentes.

También puedes realizar la operación inversa: Cambiar un área transparente por un color. Para ello, en el diálogo Pipeta, marca la casilla Transparencia, y selecciona el color por el que la reemplazarás en la lista situada a su derecha. Tras hacer clic sobre el botón Reemplazar, el cambio se llevará a cabo (Figura 23).

Draw G32 06.099.png
Figura 23: Llenar el área transparente de una imagen con un color

La lista Reemplazar por... muestra todos los colores disponibles en la paleta actual del documento. No se puede definir uno nuevo aquí, pero puedes añadir previamente los colores deseados a la paleta antes de usar la herramienta Pipeta. Más información sobre este tema en el capítulo Consejos y trucos.

Modificada el 28 ago 2015 17:09.   Visitas: 24 980