Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación. Si continúa navegando, consideramos que acepta su uso. Para obtener más información o bien conocer cómo cambiar la configuración lea nuestra Política de cookies

Convertir en polígono en OpenOffice Draw

Selecciona una imagen y desde el menú Modificar o desde su menú contextual activa Convertir > En polígono. Este comando convierte las áreas del mismo color en pequeños polígonos rellenos. Toda la imagen se convierte en un gráfico vectorial, que puede cambiar de tamaño sin pérdida de calidad en la imagen ni en el texto. El formato resultante será un metaarchivo.

Al activar el comando se presenta un diálogo que permite diversos ajustes, además de una previsualización del resultado. Convertir un gráfico en polígonos requiere mucho trabajo del ordenador, por que en función de la complejidad del gráfico, la potencia de tu equipo y los parámetros solicitados se requerirá más o menos tiempo. Cuando éste va a ser largo, una barra de progreso se incluirá en el diálogo.(Figura 25).

Draw G32 06.009.png
Figura 25: Convertir una imagen en polígonos

Draw considera entre 8 y 32 colores en la conversión, independientemente del número de colores de la imagen. Para cada color se crea un polígono que podrá constar de diferentes partes desconectadas, y se rellenarán con el color correspondiente.

El algoritmo que reduce el número de colores de la imagen al especificado no está todavía optimizado. Por esta razón, quizás prefieras previamente cambiar su profundidad de color o utilizar el filtro Posterizar.

Reducción de puntos

Los polígonos sólo serán creados si la mancha de color tiene un tamaño mayor que el valor que especifiques en Reducción de puntos. En el ejemplo mostrado bajo estas líneas se aprecia que las machas de color menores del valor especificado se desprecian.

Draw G32 06.008.png
2 pixel
Draw G32 06.007.png
3 pixel

Rellenar agujeros

Al utilizar Reducción de puntos, puede que pequeñas zonas no queden cubiertas por un polígono (agujeros). Si la opción Rellenar agujeros está marcada, cuadrados adicionales (llamados azulejos) serán creados con el color de fondo adecuado a la zona que cubren. La opción Tamaño de azulejo permite definir la anchura en píxeles de estos cuadrados.

 
Draw G32 06.006.png
Imagen original
 
Draw G32 06.005.png
Imagen original vectorizada con 16 colores y 0 pixels de Reducción de puntos
 
Draw G32 06.004.png
Imagen original transformada con el filtro Póster configurada a 64 colores...
Draw G32 06.003.png
… vectorizada con 16 colores y 0 pixels de Reducción de puntos
Draw G32 06.002.png
… vectorizada con 16 colores y una Reducción de puntos fijada a 4 píxeles, y Tamaño de azulejo fijado a 16 píxeles.

El efecto mostrado a continuación se generó utilizando la anterior imagen (posterizada y vectorizada). Los polígonos se separaron utilizando la opción Quebrar desde su menú contextual o desde el menú Modificar. Posteriormente se eliminaron algunos polígonos (6 en total) hasta que el fondo se mostró limpio.

Draw G32 06.095.png
Señal aviso.png

Para eliminar los pequeños polígonos sobrantes, selecciónalos uno a uno con la herramienta Selección de la barra de herramientas Dibujo, de forma que se mostrarán seleccionados con los manejadores de color verde, y en la barra de estado se mostrará “Polígono con nnn puntos marcado”. Pulsa entonces la tecla
Supr 
.

Quebrar y Descombinar

Si tras vectorizar una imagen utilizas el comando Quebrar obtienes un conjunto de polígonos, cada uno de ellos generado para un color determinado. Estos polígonos estarán formados por muchas partes desconectadas entre sí (Figura 26).

Draw G32 06.094.png
Figura 26: La imagen vectorizada está formada por varios polígonos (uno por color), cada uno de ellos formado por muchas partes desconectadas.
En esta imagen se está moviendo uno de los polígonos fuera del metaarchivo principal; de esta forma se observan las partes desconectadas del polígono arrastrado..

Si el metaarchivo ha sido quebrado, puedes utilizar el comando Descombinar (tanto desde el menú contextual como desde el menú Modificar) para que estos polígonos desconectados se separen en polígonos individuales (Figura 27).

Draw G32 06.093.png
Figura 27: En la imagen, el polígono que antes fue arrastrado, ha sido descombinado.
Ahora, las partes desconectadas del polígono se han separado formando polígonos individuales.

En ambos casos (tanto después de utilizar Quebrar, como después de utilizar Descombinar) si quieres operar con toda la imagen vectorizada (por ejemplo, redimensionarla) deberás agruparla.

Algunos ejemplos

Cuando la imagen ha sido vectorizada, puedes aplicar operaciones habituales de las aplicaciones de dibujo, como por ejemplo, una deformación curvada. Para estas operaciones es recomendable activar Rellenar agujeros en el proceso de vectorización, pues al crear los azulejos de fondo, los bordes de la imagen están rectos.

Draw G32 06.083.png
Draw G32 06.082.png

Estos ejemplo se han creado con las imágenes que anteriormente posterizamos y vectorizamos. Las hemos quebrado y descombinado, y finalmente, aplicado algunos de los efectos disponibles desde la barra de herramientas Modo.

En el siguiente ejemplo, vectorizaremos una letra capital de una fuente especial. Convertiremos el gráfico en polígono sin usar Reducción de puntos ni Rellenar agujeros. Usando Modificar > Quebrar obtendremos dos polígonos, como se muestra bajo estas líneas.

Draw G32 06.102.png
El polígono original (convertido de un Metafile). Al utilizar el comando Quebrar obtendremos dos polígonos (uno para el color blanco que conforman el fondo y las áreas 'vacías' de la letra, otro para el negro).
Draw G32 06.101.png
Selecciona el polígono correspondiente al color blanco (en la imagen aparece mientras es desplazado a la derecha).

Algunos trucos para seleccionarlo:

  • Pulsa sucesivamente la tecla Tab (la forma seleccionada irá cambiando con cada pulsación; repite hasta que el polígono se muestre seleccionado).
  • Hacer visible este polígono “invisible”: activando Ver > Cuadrícula > Mostrar cuadrícula (pues el polígono cubre los puntos de la cuadrícula salvo que hayas activado Ver > Cuadrícula > Cuadrícula al frente). En la figura se muestra este truco.
  • Poniendo un color de fondo a la página (desde el menú Formato > Página > pestaña Fondo > aplicar un Relleno de color).

Draw G32 06.092.png
Asigna propiedades de línea y relleno al polígono. Obtendrás una original letra capitular.

En este ejemplo se le ha aplicado un gradiente rectangular rojo-blanco con inclinación de 450, y una línea blanca continua de 0,10 cm.

Modificada el 30 ago 2015 01:00.   Visitas: 8024