Uso de cookies

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarle publicidad relacionada con sus preferencias mediante el análisis de sus hábitos de navegación. Si continúa navegando, consideramos que acepta su uso. Para obtener más información o bien conocer cómo cambiar la configuración lea nuestra Política de cookies

Anidar funciones SI para tomar decisiones en OpenOffice Calc

El uso de la función SI parece bastante sencillo. Pero lo cierto es que la utilidad de esta función se multiplica si evaluamos múltiples condiciones, y en función del resultado, tomamos una u otra decisión.

Veamos el siguiente ejemplo:

Calc.33x.15.002.png

Queremos calcular la liquidación de unas comisiones de nuestra empresa, que están en función del importe de ventas alcanzadas por cada vendedor. La progresión de las comisiones las tenemos definidas en una tabla de la hoja de cálculo.

Primera condición: Las ventas son <=15.000

Sigamos el siguiente guión:

  • Nos situamos en la celda C13
  • Invocamos al Asistente de funciones
Idea.png Puedes invocar al Asistente de funciones con la combinación de teclas Tecla Ctrl.png + Tecla F2.png
  • Seleccionamos la función SI
  • Para definir la prueba_lógica hacemos clic en la celda B13, tecleamos <= y hacemos clic en la celda B5
  • Para definir el valor_si_verdadero, hacemos clic en la celda C5

Segunda condición: Las ventas son <=30.000

Queda claro que si las ventas son menores o iguales a 15.000 se aplicará un 0% de comisión. Ahora definiremos que ocurre si las ventas son mayores a 15.000.

Esa definición se indicará en el argumento valor_si_falso, que en esta ocasión no va a ser un texto, ni el valor que contenga una celda, sino una nueva función SI anidada en la función que estamos editando. Sigamos con el guión:

  • En la línea del argumento valor_si_falso haz clic en el botón Calc.33x.15.026.png que iniciará de nuevo el asistente para anidar una nueva función
  • Selecciona otra vez la función SI. Puedes observar en el cuadro Fórmula como se va generando la expresión.
  • Para definir la prueba_lógica (de la función anidada) hacemos clic en la celda B13, tecleamos <= y hacemos clic en la celda B6
  • Para definir el valor_si_verdadero (de la función anidada), hacemos clic en la celda C6

Tercera condición: Las ventas son <=60.000

La función anidada define que si las ventas son menores o iguales a 30.000 se aplicará un 5% de comisión. Ahora definiremos que ocurre si las ventas son mayores a 30.000. Esa definición se indicará en el argumento valor_si_falso (de la función anidada), que será una nueva función SI anidada. Sigamos con el guión:

  • En la línea del argumento valor_si_falso (de la función anidada) haz clic en el botón Calc.33x.15.025.png que iniciará de nuevo el asistente para anidar una nueva función
  • Selecciona otra vez la función SI. Puedes observar en el cuadro Fórmula como se va generando la expresión.
  • Para definir la prueba_lógica (de la función anidada) hacemos clic en la celda B13, tecleamos <= y hacemos clic en la celda B7
  • Para definir el valor_si_verdadero (de la función anidada), hacemos clic en la celda C7

Cuarta condición: Las ventas son <=90.000

Hemos establecido el comportamiento para ventas menores o iguales a 60.000 Repetiremos el guión para establecer el comportamiento de las ventas menores a 90.000 anidando una nueva función SI en el argumento valor_si_falso.

  • En la línea del argumento valor_si_falso (de la función anidada) haz clic en el botón Calc.33x.15.024.png que iniciará de nuevo el asistente para anidar una nueva función
  • Selecciona otra vez la función SI. Puedes observar en el cuadro Fórmula como se va generando la expresión.
  • Para definir la prueba_lógica (de la función anidada) hacemos clic en la celda B13, tecleamos <= y hacemos clic en la celda B8
  • Para definir el valor_si_verdadero (de la función anidada), hacemos clic en la celda C8

Quinta condición: Las ventas son >90.000

  • Como es la última condición, en valor_si_falso ya no necesitamos anidar ninguna función. Estableceremos que en este caso, se aplique el porcentaje indicado en la celda C9, para lo que haremos clic sobre la misma.

La fórmula final

Podemos comprobar que el cuadro fórmula contiene la siguiente expresión:

 =SI(B13<=B5;C5;SI(B13<=B6;C6;SI(B13<=B7;C7;SI(B13<=B8;C8;C9)))) 

Ya podemos hacer clic sobre el botón Aceptar. Si todo ha ido bien, la celda C13 debe indicar como porcentaje de comisión a aplicar un 8%.

La fórmula final con referencias absolutas

Podemos repetir el proceso para las celdas C14 y C15, si bien lo correcto sería fijar aquellas celdas que en la fórmula deberían ser referencias absolutas.

Editando la fórmula de la celda C13 y utilizando la combinación de teclas Tecla Shift.png + Tecla F4.png haremos que la fórmula sea la siguiente:

 =SI(B13<=$B$5;$C$5;SI(B13<=$B$6;$C$6;SI(B13<=$B$7;$C$7;SI(B13<=$B$8;$C$8;$C$9)))) 

Las referencias que deben ser convertidas en absolutas son las de las celdas correspondientes a la tabla de criterios de liquidación. Ahora podemos copiar por referencia la fórmula de la celda C13 a las celdas C14 y C15.

Si lo deseas, prueba a modificar los valores indicados de ventas totales de cada vendedor, o los criterios de liquidación. Verás como Calc toma las decisiones correctas para calcular las comisiones de cada vendedor.

Modificada el 26 ago 2015 00:43.   Visitas: 96 699