El primer fomulario que vamos a crear en vista Diseño es uno para la tabla Interpretes que nos va a permitir introducir los intérpretes de una película.

Lo primero que vamos a hacer dentro de la ventana de edición de formularios (Figura 7.4) es indicar cómo se va a llamar el formulario y con qué tabla va a estar conectado. Para ello, pulsamos sobre el icono “Navegador de formulario” y hacemos clic con el botón derecho sobre el campo “Formulario”, elegimos la opción “Nuevo” y, dentro de ésta, “Formulario” (ver Figura 7.5).

Navegador de formulario de Writer con el menú contextual Nuevo y la opción Formulario
Figura 7.5. Creación de nuevo formulario

Por defecto, al nuevo formulario lo llama Standard pero nosotros lo vamos a renombrar como Form_Interpretes (Figura 7.6).

Navegador de formulario con el formulario nuevo renombrado como Form_Interpretes
Figura 7.6 Creación de Form_Interpretes

Para indicar que el formulario va a estar conectado con la tabla Interpretes hacemos clic con el botón derecho del ratón en el navegador de formulario sobre Form_Interpretes y elegimos “Propiedades” (Figura 7.7).

Menú contextual del formulario Form_Interpretes con la opción Propiedades seleccionada
Figura 7.7. Elección de propiedades del formulario creado

En el cuadro resultante, vamos a la ficha “Datos”, y seleccionamos dentro “Contenido”. Abrimos el menú desplegable y seleccionamos la tabla sobre la que vamos a contruir el formulario, en nuestro caso Interpretes (Figura 7.8).

Propiedades del formulario, pestaña Datos, con el tipo de contenido Tabla y la tabla Interpretes en la lista
Figura 7.8. Eleccion de tabla Interpretes

Cerramos las ventanas “Propiedades del formulario” y “Navegador de formulario” y, antes de continuar, guardamos el formulario pulsando en la pestaña “Archivo” y dentro “Guardar”, y también aquí le nombramos como Form_Interpretes (Figura 7.9).

Diálogo Guardar con el nombre de archivo Form_Interpretes
Figura 7.9. Guardado de Form_Interpretes

Ahora ya podemos continuar con la creación del formulario. En primer lugar, vamos a crear un campo de texto. Para ello, seleccionamos “Campo de texto” de entre todos los controles disponibles. Veremos que el cursor cambia de forma, y es cuando podemos insertar dicho campo. Llevamos el cursor a la posición de la zona de trabajo y lo arrastramos hasta que el campo de texto alcance el tamaño deseado (ver Figura 7.10).

Campo de texto dibujado en el documento de Writer, con sus manejadores verdes
Figura 7.10. Inclusión de un campo de texto

Ahora tenemos que dar unas propiedades al campo de texto y asignarle la tabla en la que se insertarán los datos introducidos desde este formulario. Seleccionamos dicho cuadro con el botón derecho y nos sale un cuadro emergente, y dentro de él escogemos “Campo de Control” (ver Figura 7.11).

Menú contextual del campo de texto con la opción Campo de control
Figura 7.11. Propiedades del campo de control

En el cuadro resultante, vamos a la ficha “Datos”, y seleccionamos dentro de “Campo de datos” el nombre del campo al cual se va a enlazar, en este caso, al campo Id_Interprete (ver Figura 7.12).

Propiedades del campo de texto, pestaña Datos, con el campo de datos Id_Interprete seleccionado
Figura 7.12. Propiedad “Campo de Datos”

Dentro de esta misma ventana de propiedades del campo, nos vamos a la ficha “General” al campo “Nombre” y escribimos CampoId_Interprete (Figura 7.13). Una buena práctica es dar un nombre significativo a cada campo que creemos, sobre todo cuando tengamos formularios con muchos campos. Así, podremos distinguir bien cada campo dentro de la ventana “Navegador de Formularios”.

Propiedades del campo de texto, pestaña General, con el nombre CampoId_Interprete
Figura 7.13. Indicación de nombre del campo

Delante del campo de texto creado vamos a poner un “Campo etiqueta” (ver Figura 7.14) para que cualquier usuario que utilice el formulario conozca lo que debe introducir.

Campo de etiqueta junto al campo de texto en el formulario
Figura 7.14. Inclusión de campo etiqueta

Si hacemos doble clic sobre la etiqueta aparecerá una ventana (ver Figura 7.15) donde podremos indicar las diferentes propiedades de la etiqueta (nombre que aparecerá en la etiqueta, color de fondo, tipo de letra, tamaño, color,…). El formato de los formularios puede tener más colorido y distintas fuentes de texto pero el conocer y cambiar los distintos formatos entra dentro de los contenidos del curso de OOo Writer y no de éste por lo que se remite al alumno a dicho curso para aprender más sobre este tema.

Propiedades del campo de etiqueta con el título Identificador de intérpretes, alineación centrada y color de fondo Amarillo 2
Figura 7.15. Propiedades del Campo de Etiqueta

Dentro de estas propiedades vemos que hay algunas que nos abren una nueva ventana como, por ejemplo, la propiedad “Fuente” (Ver Figura 7.16) donde podemos variar el tamaño y el tipo de la fuente del texto.

Diálogo de caracteres con la fuente Tahoma, estilo Negrita y tamaño 11
Figura 7.16. Propiedad Fuente del Campo de etiqueta

Una vez que hemos cambiado las propiedades de la etiqueta, nuestro formulario debería parecerse al de la figura 7.17.

Etiqueta Identificador de intérpretes con fondo amarillo junto a su campo de texto
Figura 7.17. Formulario tras cambio de propiedades de etiqueta

Si repetimos los pasos realizados para el resto de los campos de la tabla Interpretes podríamos obtener un formulario parecido al de la Figura 7.18.

Formulario con las etiquetas Identificador de intérpretes, Nombre, Apellidos y Nacionalidad y sus campos de texto
Figura 7.18. Formulario Form_Interpretes con todos los campos incluidos

Si salvamos los cambios realizados y cerramos la ventana de edición de formularios, en la ventana de objetos ya debe aparecer el formulario que acabamos de crear (Figura 7.19).

Ventana de OpenOffice Base con el formulario Form_Interpretes en la lista de formularios
Figura 7.19. Ventana de objetos con nuevo formulario

Si queremos realizar algún cambio en el formato del formulario, pulsamos sobre el formulario con el botón derecho del ratón y elegimos la opción ‘Editar’ (Figura 7.20).

Menú contextual del formulario Form_Interpretes con las opciones Copiar, Eliminar, Cambiar nombre, Editar y Abrir
Figura 7.20. Editar formulario creado

En cambio, si lo que queremos es ejecutar el formulario para empezar a insertar datos (ver Figura 7.21) hacemos doble clic sobre él .

Formulario Form_Interpretes abierto con los datos de un intérprete y la barra de navegación de formularios señalada en rojo
Figura 7.21. Ver e insertar datos en formulario

Para movernos entre los diferentes registros y realizar distintas operaciones sobre ellos, usaremos la barra “Navegación de Formularios” que nos aparece en la parte inferior (Figura 7.21) en la que destacan los siguientes elementos:

Base 20 07.007.png
Búsqueda de registros
Botones de navegación de registros de un formulario
Desplazamiento entre registros
Base 20 07.005.png
Inserción de nuevo registro
Base 20 07.004.png
Guardar cambios registro
Base 20 07.003.png
Deshacer entrada de datos
Base 20 07.002.png
Eliminación del registro actual